Paylater currently only supports Android devices running on version 4.1 and above. Please check your device settings to verify whether your device meets this standard.